mercredi 30 septembre 2009

Votre serveur dans le cloud

Par Thierry Lévy-Abégnoli le 01/10/2009 - vu sur indexel.net

Le cloud computing recouvre des services d'externalisation qui remettent souvent en cause l'existant. Ce n'est pas le cas de la location de serveurs virtuels x86, un service "cloud" qui permet de reprendre aisément d'anciennes applications

1. Des serveurs virtuels traditionnels mais hébergés

Le principe du cloud appliqué aux serveurs x86 consiste à louer des machines virtuelles qui restent chez un hébergeur, donc "dans le nuage". "Un serveur virtuel situé par exemple chez Amazon se comporte sensiblement comme s'il restait dans l'entreprise", affirme Pascal Ognibène, directeur technique chez Valtech Paris. On peut même envisager de migrer purement et simplement vers le cloud, des serveurs existants, avec toutefois une limitation dans certaines offres : il n'est pas possible de transférer telle qu'elle l'image d'une machine virtuelle existante.

2. Une offre en pleine explosion

Parmi les prestataires de tels services, Amazon, avec son offre EC2 (Elastic Compute Cloud) reste le plus connu. D'autres spécialistes tirent leur épingle du jeu, comme le Français Gandi. Et l'on assiste depuis quelques mois à une arrivée massive des opérateurs et des hébergeurs comme Claranet, Orange, Colt ou BT Global Services. Ces deux derniers ciblent en priorité les grands comptes, tandis qu'Orange se targue d'adresser autant les PME que les grandes entreprises.

3. Une mise en œuvre en quelques heures

Dans la plupart des offres, les serveurs virtuels sont généralement créés à distance, via un portail, en puisant dans un catalogue de configurations correspondant à des ressources différentes (puissance, mémoire, espace disque). Une telle machine virtuelle n'est jamais totalement nue, dans la mesure où le client doit sélectionner un système (Windows ou distribution Linux), ce choix déterminant l'image qui sera déployée. Enfin, les composants techniques et applicatifs, gratuits ou payants, sont également puisés dans des catalogues.

Certaines offres donnent ensuite toute liberté au client pour installer d'autres applications, éventuellement spécifiques, via un accès direct au système. À l'inverse, des prestataires proposent des images de machines virtuelles correspondant à des packages (systèmes et applications), ou prennent en charge tout le processus de déploiement. "Le client peut avoir une liberté totale mais si les installations sont réalisées par nos soins, il bénéfice de garanties de service supérieures",Maël Rivoal, responsable avant-vente chez Claranet. signale

4. Une évolution en fonction des besoins

Une offre cloud présente l'avantage de permettre d'allouer ponctuellement des ressources informatiques en fonction des besoins ou, au contraire, de réduire la voilure. Ce processus n'offre toutefois pas une évolutivité continue et instantanée, ni une granularité très fine. "Par exemple, chez Amazon, la puissance d'une machine virtuelle correspond à un à quatre Xeon à 1,7 GHz, impossible de monter plus haut", explique Pascal Ognibène . Chez Claranet, il est possible de créer des machines virtuelles comptant jusqu'à 32 Go et 8 cœurs Xeon (biprocesseur quadcore). Certains prestataires, comme Colt, Orange et bientôt Claranet, affirment que les mises à jour sont réalisées à chaud, presque sans interruption de service.

"Parallèlement à cette évolutivité verticale, on peut cloner des serveurs virtuels sur lesquels la charge sera répartie, afin d'évoluer horizontalement", précise Pascal Ognibène. Enfin, quelques hébergeurs proposent, lorsque le besoin s'en fait sentir, de passer à une offre dédiée, donc basée sur des serveurs physiques.

5. Des coûts difficilement comparables

Les coûts varient énormément en fonction des engagements de services, des ressources allouées, des applications et systèmes installés et des services délivrés : conseil, alertes lorsque des serveurs approchent de la saturation, contrat de niveau de service (SLA) ou, encore, plan de reprise d'activité (PRA). Mais la plupart des prestataires adoptent un système de tarification par mois et par serveur virtuel (respectivement 15 et 800 euros), avec un espace disque standard (par exemple 10 Go) au-delà duquel la facture s'allonge (20 centimes par mois et par Go chez Gandi).

L'engagement minimum demandé à l'entreprise est également très variable. Claranet impose au moins un mois. Amazon et Gandi proposent une location à l'heure. À l'inverse, BT demande au client de s'engager sur un minimum de 30 serveurs virtuels, soit un budget d'au moins 6 000 euros. "Nous ciblons les entreprises dont le chiffre d'affaires est d'au moins 500 millions d'euros", justifie Francois Guiraud, directeur offres et services chez BT.
Les offres de location de serveurs virtuels


mardi 29 septembre 2009

Oracle-Pillar Data-Sun : on passe aux choses sérieuses sur la plate-forme de test

Bon assez joué, aujourd"hui, je vais procéder à l'install de Oracle 11gr2 RAC sur une infra vSphere/Sun XEON 5500 dédiée. Les VMs seront de type Red Hat Entreprise 5 x64. Bien entendu, j'abuserai largement de Oracle ASM et de la QOS Pillar qui sera mise à profit pour l'optimisation des index et des Rollback Segments stockés sur les SSD. Ensuite, import des données de notre prod et tests avec les utilisateurs.

FCOE commence à buzzer sur la toile

Vu sur le blog Cisco Datacenter par Omar Sultan


Fibre Channel over Ethernet (FCoE) seems to be a popular topic for the last couple of weeks. There have been a number of useful posts that I have ran across recently that I thought I would share:

* Nigel Poulton (@nigelpoulton) has a couple of great posts on some of the fundamentals of FCoE technology
* Mark Twomey (@storagezilla) followed up on Nigel’s efforts with a post on the EMC FCoE Techbook which goes into bleeding-eyeballs detail on how to set up environment.

For our part, we have just posted a new white paper on FCoE Initialization Protocol, which was defined as part of FC-BB-5. FCoE Initialization Protocol supports many of the same functions as FIP in the Fibre Channel world (Fabric LOGIn, Fabric DISCovery, Exchange Link Parameters) in order to establish and maintain the virtual link between an FCoE End Node and an FCoE Forwarder (FCF) such as the Cisco Nexus 5000 that defines the edge of the fibre channel fabric. Amongst other things, that lets us build more sophisticated network topologies as we deploy an FCoE based unified fabric. Up to this point, End Nodes have had to be directly attached to the FCF; however, with FIP, you can have intermediate “passthrough” switches between the End Node and the FCF (as long as they meet certain criteria, laid out in the white paper). A quick example of where this might be helpful is a blade server chassis, where you might not want the cost and/or complexity of a full FCF in the chassis, but do want a switch that can serve as an FCoE passthrough to properly forward the FCoE traffic to an FCF.

Finally, its nice to hear from customers on the topic. To that end, Derek Masseth, Senior Director for Infrastructure Services at the University of Arizona, will be joining us on a webcast tomorrow to discuss his experiences with deploying unified fabric in his environment. The balance of the webcast will give you an update on some other goings on with storage as well as some new products on the horizon.

The Webcast is tomorrow, Tuesday, September 29, 2009, 10:00-11:00 a.m. PDT. It can be accessed at http://tools.cisco.com/cmn/jsp/index.jsp?id=90342 (no registration required, just go to the URL at 10:00 a.m. PDT and select “Play” to launch the live presentation).

Posted by Omar Sultan at 10:19AM PST

dimanche 27 septembre 2009

Saga : Controverse au sujet du post 'un petit bench pour la route'., 3eme Partie

Update :

Entre deux troubleshouts réseaux, je me suis cloné une petite infra VMware view 3.12.
Le provisionning de 300 clones liés à pris environ .... 5 secondes :) et a généré 50K iops.

Commentaire posté par BEND78 :

"Vous obtenez donc dans les 4Gb/s par VM... ce qui donne 20Gb/s pour l'ensemble des 5 VMs !
Très impressionnant ces disques SSD...
Néanmoins un test "iometer" pourrait être plus parlant pour voir les gains sur les accès aléatoires. "

Mon cher BEND78, je pense qu'il va vous falloir raisonner autrement qu'avec les stockages traditionnels en voyant comment fonctionne un Pillar Data. Un disque SATA traditionnel est très performant en I/Os séquentielles mais pas aléatoires. Un disque FC, c'est rigoureusement l'inverse. L'architecture Pillar permet de transformer toutes les I/Os aléatoires en I/Os séquentielles. Autrement dit, séquentielles ou aléatoires, les performances I/Os sont rigoureusement les mêmes ! Sinon, je n'aime pas IOMETER car il faut faire un bench manuellement ligne par ligne alors qu'ATTO permet de voir les résultats comparatifs de manière globale. Toutefois, je me plie à la démonstration avec IOMETER en prenant la première ligne venue 8K, sans optimisation particulière du point de vue des blocs utilisés par le stripping en l'occurrence sans m'occuper des profils applicatifs optimisés proposés par Pillar :

8k, 100% random 50% R/W


Résultat


8k, 100% séquentielle 50% R/W


C'est la même chose !

On note un léger overhead CPU lié à la génération des blocs disque eux-mêmes.
Donc : un système Pillar Data est prédictif, réagit de la même manière en accès aléatoire ou séquentiel. Vous comprenez donc que ATTO, qui ne traite que du séquentiel, permet de connaitre les performances du stockage dans tous les modes. Le SSD apporte de la bande passante supplémentaire ainsi que de l'équillibrage des lectures et des écritures sans hardware spécialisé dédié. En résumé : on peut intégrer des briques SSD et en tirer immédiatement le meilleur parti.

PS : pour le second message, j'ai forwardé à Pillar Data et j'attends la réponse que je publierai. Merci pour vos remarques pertinentes.

Le Virtualization Technical Center ou VTC chez Amosdec






La très complète plate-forme V.T.C. et formation d'Amosdec.

samedi 26 septembre 2009

Saga : Controverse au sujet du post 'un petit bench pour la route'.

Selon Pillar Data, le choix de disques Intel SLC SSD est tout à fait volontaire et entre dans la philosophie du produit : utiliser des périphériques courants voir 'grand public' pour en tirer les meilleurs performances. A titre d'exemple, une baie Pillar SATA est capable de délivrer les même performances qu'une baire concurrente équipée de disques Fiber Channel 15K mais en s'appuyant sur le même type de disque qui équipe votre PC à la maison. Mieux, compte tenu de l'utilisation optimisée, là où un disque SATA à une durée de vie de 600 000h, chez Pillar il voit sa durée de vie passer à 1 600 000 h (mesuré avec les call home de l'ensemble des baies des clients en production). On peut imaginer que le fait d'utiliser des périphériques très haut de gamme à une répercussion sur le prix final et l'utilisation finalement dispendieuse faite sur le matériel traditionnel ....


Atto sur dans une VM un lien unique FC4 (FCOE).
J'en ai lancé 5 dans 5 VM en simultané.
On note un très bon équillibre entre les lectures et les écritures.
Il est clair que la machine en a sous le pied.

vendredi 25 septembre 2009

Controverse au sujet du post 'un petit bench pour la route', suite

Voici la suite de la saga http://ds45.blogspot.com/2009/09/petit-bench-pour-la-route.html dans lequel je m'étais amusé à publier les performances d'un NetAPP Fas2020 vs Pillar Axiom 500 (mais aussi 300 puisque c'est la même machine) . Un commentaire désobligeant avait été posté par rapport à l'entreprise Pillar Data. La direction commerciale de Pillar Data Systems a souhaité réagir en la personne de M. Harry Zarrouk, je vous publie intégralement le mail qu'il m'a envoyé

"Monsieur Parcollet,

Je peux être plus précis sur les salariés de la filiale française, qui rentre dans le P&L de l’Organisation France :

* 3 personnes sur les ventes, 2 personnes sur la télévente.

* 1 personne au channel partenaire partagé entre la France et l’Europe du Sud
* 3 personnes sur l’avant-vente et le TAM France

* 2 personnes à l’ingénierie d’escalade pour le marché français basé en Irlande.
* 3 personnes sur le PS, dont 2 indépendants.
* 1 Juriste partagé entre la France et l’Europe du Sud.

* 1 personne en charge du marketing communication et partenaire.
* 1 personne en charge du marketing stratégique partagée entre France et Europe du Sud.
* 2 recrutements en cours : un commercial pour le Nord et un commercial dans le sud Ouest.

A cela s’ajoute des ressources financées à 50% par nous et 50% par nos partenaires pour les activités de Chef Produit chez les partenaires (ce que l’on appelle les funded head). Ces personnes sont en partie financées par Pillar France
Si vous voulez de plus amples informations, contactez leur Directeur des Ventes France et Belgique, Harry Zarrouk"

Nous sommes donc loin des 5 personnes qui composeraient l'équipe. Concernant les aspects techniques, j'attends une réponse de Pillar Data US sur le choix des disques SSD SLC INTEL.

A suivre donc ...

mercredi 23 septembre 2009

Les processeurs Intel pour les 3 ans à venir

Vu sur 01Net par Yann Serra le 23/09/2009

Paul Ottelini, PDG d'Intel, a fait l'ouverture de l'IDF 2009 en annonçant avoir réussi une première gravure en 22 nanomètres. Une innovation qui prépare la prochaine génération de processeurs du fondeur.

Paul Otellini, le président d'Intel, a ouvert la dernière édition du salon IDF sur la présentation d'une puce électronique dont les transistors mesurent 22 nm, soit deux fois moins que ceux des derniers Core i7. La fabrication des processeurs à cette échelle ne sera pas industrialisée avant, au mieux, la fin 2012. A ce moment-là, une telle miniaturisation multipliera par quatre la densité d'un processeur tel que nous le connaissons, ouvrant la voie à de futurs Core et Xeon dotés de 32 cœurs et de 96 Mo de cache.
On sait déjà que ces cœurs ne seront pas forcément tous dédiés au calcul. Des cœurs graphiques avec fonctions vectorielles, et d'autres spécialisés dans la cryptographie sont prévus. Ils feront d'ailleurs leur apparition dès la prochaine génération Sandy Bridge de processeurs. Intel entend la lancer vers la fin 2010, avec une gravure intermédiaire de 32 nm. Dès lors, les modèles de processeurs se multiplieront. Le processeur Larrabee aura par exemple un maximum de cœurs graphiques.

Diminuer les watts ou augmenter les gigahertz
D'ici là, les processeurs actuels de la génération Nehalem, jusqu'ici gravés en 45 nm, vont également bénéficier de la gravure en 32 nm au début de 2010. Intel compte tirer partie de cette réduction de taille de plusieurs manières. Il s'en servira tantôt pour diminuer les watts, tantôt pour augmenter les gigahetrz des serveurs, des PC et des portables, selon les marchés visés.

Il est aussi question d'utiliser le gain de place pour insérer dans le boîtier de la puce un composant jusqu'ici externe. Intel distribuera Westmere, un Core i7 doublé d'une puce graphique, les deux circuits étant reliés par un bus PCI-E interne.
Il fournira également aux industriels une déclinaison Jasper Forest de ce processeur, dénué du composant graphique. Le but étant de proposer aux fabricants de baies de stockage, commutateurs réseaux et autres boîtiers spécialisés, la base sur laquelle greffer un contrôleur disque, Ethernet, Wi-Fi ou VoIP afin de produire des solutions avec moins de composants, donc moins chères et plus économes en énergie.

Petit bench pour la route

Update : compte tenu des réactions suscitées à la suite de ce post - mon blackberry est en train d'agoniser-, je vais demander si Pillar Data souhaite publier ici-même une réponse que je trouve légitîme notamment sur la santé de l'entreprise, le nombre d'employés en France et sur le choix du type de SSD.

En prenant plus de hauteur, je trouve que l'histoire se répète en ce sens que ce genre de méthode de dénigrement était employée il y a quelques années par EMC à l'encontre de NetAPP lorsque cette dernière a commencé à être visible sur le marché. Souhaitons que ce soit de bonne augure puisque nombre d'employés Pillar proviennent de chez NetAPP, notamment en France. Mieux : en tant que client, ce type d'arguments qui devraient me faire fuir à tendance à me mettre la puce à l'oreille et je demande à en savoir plus .... Peut-être celà incitera-t-il aussi les quelques lecteurs de ce modeste blog à utiliser l'outil ATTO Benchmark pour voir si ce qu'on leur a vendu est vrai. Dans la vraie vie, on ne fait pas toujours du tuning spécifique pour obtenir les meilleures performances, c'est d'ailleurs l'un des crédos de Pillar Data : on crée des espaces de stockage en se penchant sur les contraintes de l'applicatif ou du SLA demandé par l'utilisateur, pas sur ceux imposés par la technique.

Il y a tout juste un an, j'étais présenté comme le 100e client Pillar EMEA, aujourd'hui ce sont plus de 100 clients français qui font confiance à Pillar Data. Probablement dans ces gens, une majorité d'entre eux tout comme moi, ne comprend rien à ce qu'est un SAN, aux avantages de la QOS ou d'un stockage répartit par rapport au stockage monolitique.

Ce post n'est nullement anti-NetAPP d'autant que j'affectionne particulièrement le NAS et ce n'est pas l'OpenFiler herbergé dans mon garage qui dira le contraire. Ca désespère même Gilles H. du Professionnal Services Pillar (ancien NetAPP) . Tout comme le réseau, le stockage est un monde passionnant où l'on en apprend tous les jours, y compris sur les gens.

Profitant de ma formation chez Amosdec, je n'ai pas pu résister à faire un petit test de perf comparatif sur l'un des Fas NetAPP 250 présents et l'un de nos PDS Axiom 500. Le premier est en FC 4 et hébergerait 200 VMs, le second est en prod avec 130 VM -73 serveurs, le reste View 3-. Simplement si l'on cherche à vous faire croire qu'un FAS2050 est aussi performant qu'un Pillar Data Systems Axiom, demandez à réaliser un POC. Le Fiber Channel ne fait pas tout ....

Update : On m'a menti !!!! En fait, le NetAPP est un FAS2020 et pas un Fas250.


Voici la machine en question.

mardi 22 septembre 2009

Telex : Une partie de la semaine en compagnie de Julien

Cette semaine, J'aurai passé beaucoup de temps en compagnie de mon ami Julien Mousuqueton co-animateur du vmug.fr, vExpert d'abord lundi chez Cisco pour échanger avec Jim Capobianco, Maurizio Portaliani, Eric Debray et une partie de l'équipe datacenter France, puis ensuite mardi et mercredi au centre de formation de Amosdec où nous suivons la formation vSphere 'What's new ?'

Grosses ambitions pour Oracle 11Gr2

Ce moteur sera prochainement déployé à la SETAO sur une baie SSD Pillar Data en vue d'un bench.

Vu sur le MagIT-Le 22 septembre 2009 (18:48) - par Cyrille Chausson

Compression, optimisation, mode en cluster, partitionning sont les points forts d'Oracle 11g R2 , la seconde mouture de la base de données Oracle 11g. Une version dont la mission est de permettre au géant de maintenir son rang de numéro 1 mondial du secteur. La réussite de cette mission passera largement par la séduction d'une large partie de sa base installée, toujours sur 10g.

C'est officiel : Oracle a mis à disposition via l'Oracle Technology Network (OTN), l'extranet destiné à ses utilisateurs, la version R2 d'Oracle 11g, son système de gestion de bases de données relationnelles. Oracle contrôle aujourd'hui presque 50% du marché mondial du secteur (en revenus). C'est dire l'importance pour l'éditeur du lancement de cette deuxième évolution alors que la firme peine à se sortir des griffes de la commission à la concurrence de l''Union européenne pour le rachat de Sun- et donc de MySQL. L'arrivée d'Oracle 11g se fait par ailleurs alors que la crise et passé par là, et que même si une timide reprise seble pointer à l'horizon, les budgets IT des entreprises restent largement en baisse.

Rien d'étonnant alors que l'heure soit à l'optimisation et à la consolidation. Deux termes que Mark Townsend, vice-président des activités Database Product Management chez Oracle a martelés à l'occasion d'un passage à Paris pour mettre en avant les qualités de 11g R2.

Au programme, Mark Townsend a notamment vanté les avancés apportés dans R2 notamment sur Oracle Real Application Cluster (RAC) qui permet une intégration de la base dans une architecture de Grid pour répartir et adapter la charge entre de multiples serveurs - ou pour bâtir des architectures plus tolérantes aux pannes. Il est aussi revenu sur RAC One Node, une déclinaison limitée de RAC qui permet notamment de protéger un petit cluster de serveurs Oracle contre les pannes et qui vise plutôt les applications moins critiques - entendez par là que la licence One Node devrait être moins chère qu'une licence RAC. Oracle RAC One Node permettra notamment le redémarrage à la volée d’une base de données sur un autre noeud du cluster en cas d’erreur sur le noeud original,mais aussi la migration sans interruption d’une instance de base d’un serveur à un autre (à la vMotion pour les machines virtuelles). RAC One Node devrait aussi simplifier les migrations et les upgrades

Oracle a également étendu des outils de gestion de stockage automatisé (Automatic Storage Management – ASM) avec une nouvelle brique : ASM Cluster File System, un module qui s'adapte en fonction du cycle de vie des données (actives ou passives) et propose un puissant outil de partionning en fonction de leur valeur d'activité. Dans le même ordre idée, Oracle a inauguré des fonctions de compression de données (Advanced OLTP Compression et Hybrid Columnar compression), qui selon lui permettent de réduire jusqu'à 4 fois l'espace occupé.

Un point qui constitue un des gros avantage de la R2, explique Jean Louis Paoli, chef de projet chez Marseille Gyptis International, qui intervient notamment dans la mise en place d'un système informatique de gestion logistique de la zone portuaire de Marseille. « Même si aujourd'hui les retours sur expérience sont faibles, R2 rassure d'autant plus que les problèmes de jeunesses sont résolus. Pour lui, la compression et les outils d'optimisation sont très liés au facteur performance de la base et c'est bien là que réside un de ses points forts. Lui et sa société, déjà équipé de 10g, évaluent une migration vers 11g R2, un processus qui comprend également le hardware. Notons au passage que Mark Townsend a également rappelé que le groupe s'efforçait de renforcer l'optimisation de la base sur les plates-formes de Sun.

Reste donc à convaincre les utilisateurs. Et Mark Townsend demeure confiant. « Entre 70 et 75% de notre base installée est sous 10g. J'estime que la moitié serait prêt à migrer vers R2, soit 35% de notre base en un an. » Pas de souci donc, les coûts de migration sur lequel il est resté très flou (il parle d'un quart de coûts de la mise à jour) ne seront pas impactants estime Oracle - ce qui reste à démontrer.

Pas de souci non plus quant à l'arrivée sur le marché de SQL Server 2008 R2, le serveur de bases de données de Microsoft prévu pour la mi-2010. Si l'on en croit Mark Townsend, « Microsoft et IBM ne font que suivre Oracle, avec un certain décalage». Si Oracle semble en effet conserver un certain leadership technologique, ses deux concurrents se font toutefois un malin plaisir d'appuyer là où celà fait mal : leur prix, souvent sensiblement inférieurs à celui d'Oracle. Crise aidant, il sera intéressant de voir si ce facteur prend le dessus sur les considérations pûrement technique chez certains comptes.

lundi 21 septembre 2009

vendredi 18 septembre 2009

Pillar deliver SSD Storage Systems



I'd received yesterday our 3rd storage system AXIOM 600 from Pillar Data. This one will use SSD drives !! The purpose is to run intensives Oracle's Databases and provisionning VMs for VMware View. Inside tray, an Intel SLC SSD looks like a 2"5 drive. FYI, such a drive may deliver up to 1000 I/Os and is 20 times faster as a FC 15K drive :) I think we will increase a few little our performances.

mercredi 16 septembre 2009

Oracle Exadata v2 : sans HP mais avec Sun

The Sun Oracle Database Machine is the world's fastest for any type of database workload, and the only database machine that runs transaction processing applications. It is a complete package of software, servers, storage and networking for all data management, including data warehousing, transaction processing and consolidated mixed application workloads. The Sun Oracle Database Machine also includes Sun's new FlashFire technology to cache 'hot' data for dramatically improved transaction response times and throughput. With the Sun Oracle Database Machine, customers can consolidate all their database applications, store up to ten times more data, search data up to ten times faster, and make faster business decisions in real time without making changes to applications.

Oracle Exadata Storage Servers
At the heart of this system is the Oracle Exadata Storage Servers, which has smart storage software built in. The smart storage software offloads data-intensive query processing from Oracle Database 11g servers and brings it closer to the data. As a result, much less data travels over the server's fast InfiniBand interconnects—dramatically improving both query performance and concurrency for transaction processing and data warehousing applications.

Choice of Configurations
The Sun Oracle Database Machine is available in a choice of configurations that scale from a basic system to a 42-unit rack complete with 8 database servers and 14 Oracle Exadata Storage Servers.

Vu sur le site Oracle : Oracle buys Sun

Visiblement Oracle ne semble pas prêt à démenteler Sun pour le vendre à HP contrairement à ce que l'on a laissé entendre ici ou là sur la toile ...


... Vu en allant télécharger Oracle 11R2 pour la mise en place sur une baie SSD Pillar Data.

mardi 15 septembre 2009

Scott Davis, Ex- Virtual Iron, chez VMware

Vu sur Virtualization.info : Posted by Alessandro Perilli | Monday, September 14, 2009

In mid-July virtualization.info unveiled that VMware was looking for a second CTO, who could take care of a desktop virtualization business unit that includes View, ThinApp, the Client Virtualization Platform (CVP), the new Virtual Profiles product OEM’ed from RTO Software, and more.

To cover this role VMware didn’t hire an external resource but promoted its Chief Data Center Architect, Scott Davis, co-founder and former President and CTO at Virtual Iron (acquired by Oracle in May).

Davis is in VMware since April 2007, but VMware formally presented him as CTO only at VMworld 2009.
This move should unload the growing responsibility of Steve Herrod, who leads the VMware technical effort since December 2001.

Pat Gelsinger chez EMC

Vu sur le MagIT : le 14 septembre 2009 (11:06) - par Reynald Fléchaux

La succession annoncée des Pdg d'Intel et d'EMC aiguise les appétits au sein des deux groupes. Pat Gelsinger, le responsable de la division entreprise du fondeur, déboule chez le géant du stockage, où il prendra la responsabilité de la principale activité du groupe. Pour se poser en successeur potentiel de l'actuel Pdg d'EMC, Joe Tucci.

Selon le New York Times, Pat Gelsinger, un des hommes clefs d'Intel, est en passe de quitter le fondeur pour rejoindre EMC. Vice-président d'Intel en charge de la division entreprise - l'activité la plus importante du groupe, pesant plus de la moitié du chiffre d'affaires -, Pat Gelsinger a passé quelque 30 ans au sein de la société, occupant divers postes (notamment directeur technique et responsable de la recherche). Selon le Wall Street Journal, chez EMC, le dirigeant aurait la responsabilité opérationnelle de la division stockage et d'autres branches logicielles du groupe.

Redistribution des cartes chez Intel

Le départ de Pat Gelsinger prépare une redistribution des rôles au sein d'Intel. Sean Maloney, actuel responsable des ventes et du marketing, verrait ainsi son rôle élargi. Selon le New York Times, ce dernier superviserait désormais l'ensemble des activités micro-processeurs du groupe (PC, serveurs et puces graphiques), tandis que Dadi Perlmutter, directeur de l'entité puces pour portables, prendrait en charge le développement de l'ensemble des gammes de micro-processeurs.

En toile de fond se dessine la succession des Pdg actuels à la tête des deux groupes. Ainsi, Sean Maloney est souvent considéré comme le remplaçant de Paul Otellini, actuellement à la tête du fondeur. L'arrivée de Pat Gelsinger - 48 ans - chez EMC intervient également dans un contexte de succession de l'actuel Pdg du géant du stockage, Joe Tucci. Dans l'organisation d'EMC, Gelsinger prendra d'ailleurs le poste clef qu'occupait jusqu'à fin avril David Donatelli, qui a démissionné pour rejoindre HP. Un départ surprise, car ce dernier était justement pressenti pour prendre la succession de l'ombrageux Joe Tucci. David Donatelli était considéré comme la personne qui a orienté la stratégie stockage d'EMC.

Trois postulants, un seul élu ?

En prenant la tête de la principale division du groupe, Pat Gelsinger se pose donc en successeur possible de Joe Tucci - 62 ans -, qui a annoncé vouloir quitter son poste de Pdg dans trois ans. Mais d'autres dirigeants sont également en lice, comme Howard Elias (52 ans, à la tête de la division services) et David Goulden (50 ans, le directeur financier). Rappelons que des rumeurs de rachat par Cisco entourent également le géant du stockage. Il y a quelques jours, nos confrères de The Register attribuait aux deux groupes la volonté de mettre en place une co-entreprise.

lundi 14 septembre 2009

Ethernet 100 Giga pour la (très) courte et (très) longue distance

Vu sur indexel.net Par Thierry Lévy-Abégnoli le 10/09/2009 : 100 Gigabit Ethernet : à partir de 2010

Dès 2010, le 100 Gigabit Ethernet offrira des débits dix mille fois supérieurs à l’Ethernet originel. Les opérateurs télécom seront les premiers intéressés mais à terme, la nouvelle norme sera mise en œuvre jusque dans les châssis de serveurs lames.

L'Ethernet a démarré il y a plus de 25 ans avec un débit de 10 Mbit/s. Aujourd'hui, le Gigabit commence à se banaliser sur le poste de travail, tandis que le 10 Gigabit fait de même dans le datacenter. Et pas seulement sur les cœurs de réseau, puisque les châssis de serveurs lames sont équipés de telles interfaces, qui permettent de faire transiter les débits générés par l'ensemble des lames.

Mais voici que l'on voit poindre aujourd'hui le 100 Gigabit Ethernet. Les travaux de normalisation sont en cours à l'IEEE et ne devraient pas être terminés avant la mi-2010. Pour autant, les démonstrations de constructeurs comme Cisco, Juniper ou Infinera se succèdent. Elles sont réalisées sur de longues distances - plusieurs centaines de kilomètres - car la nouvelle norme ciblera dans un premier temps les opérateurs nationaux et internationaux.

Pour autant, la technologie n'est pas encore prête, du moins pas sur l'ensemble de la chaîne. "Au niveau des unités de traitement permettant le routage des paquets IP, notre châssis T 1600 peut d'ores-et-déjà supporter de tels débits, par exemple par agrégation de canaux 10 gigabits", affirme Ahmed Guetari (photo), directeur technique service providers pour l'Europe chez Juniper.

Tester le marché : Mais pour la partie transport sur fibre optique, les choses sont plus compliquées. Actuellement, aucun équipement ne permet de faire passer 100 gigabits sur une fibre, en utilisant une seule longueur d'onde.

"Cela ne devrait être possible que fin 2010 voire en 2011", estime Serge Melle (photo), vice-président et directeur technique chez Infinera, l'un des spécialistes de cette partie optique. En attendant, Infinera a développé une puce photonique capable de multiplexer, sur dix longueurs d'onde différentes, dix fois 10 Gbit/s, soit les 100 Gigabit requis. "Cette solution permettra de tester le marché", précise Serge Melle.

À moyen terme, on entrevoit également l'entrée du 100 Gigabit dans les centres informatiques. "Il est en effet prévu de décliner la norme pour le cuivre, sur des distances de dix mètres, voire un mètre à l'intérieur d'un châssis", explique Ahmed Guetari. D'ici deux à trois ans, on pourrait ainsi retrouver le 100 Gigabit Ethernet dans des châssis de serveurs lames haut de gamme.

dimanche 13 septembre 2009

Séance culture 11 : L'arrangeur Roland VA-7



Les jours commencent à raccourcir, le vent se lève annonçant l'approche de l'automne et des belles couleurs dans les arbres de nos forêts.C'est aussi le moment de rentrer en studio pour coucher en musique l'insipration acquise lors de cet été radieu qui se finit. Et pour produire rapidement de la musique, j'utilise un outil absolument génial permettant de créer un morceau en moins de temps qu'il ne faut pour l'écrire : un arrangeur et peut-être l'un des plus aboutis de tous le Roland VA-7. Cette machine, se suffisant à elle-même, constitue une sorte de home studio intégré que l'on peut prendre sous le bras le wek-end (15 kg qu and même) On y trouve une bibliothèque de 3649 sons (modifiables) provenant notamment des Jupiter et autre Juno, un échantilloneur variphrase polyphonique -qui fait du time stretching automatiquement, autrement dit le son fait la même durée quelque soit la note tout comme le Roland VP 9000 -, 116 kits de batterie, un séquenceur 16 pistes, 1 controlleur d-beam -on passe la main au travers d'un rayon infrarouge et on fait varier la hauteur comme la harpe laser de JMJ-, un pitch bend et un ruban pour faire varier la hauteur, un écran tactile et le tout avec 128 voix de polyphonie.La partie arrangeur permet d'importer des séquences midi et de s'en servir pour accompagner la main droite. On peut les ré-agencer à l'aide du fonction composeur plutôt intuitive. Chaque piste d'accompagnement peut être rappelée individuellement ou en groupe au travers de la fonction 'band'. La machine peut être acquise rien que pour l'échantillonneur qui est vraiment exceptionnel de simplicité. Pour exporter/importer un lecteur de disquette et un lecteur ZIP 128Mo complètent le tout. Bref cette machine est une véritable faiseuse de tube.


En rouge, l'échantillonneur Variphrase, en vert, l'accès aux sons

A voir sur Youtube,
Demo du Roland vA-7 : http://www.youtube.com/watch?v=z7Ze0zxtC-s
Fort Boyard : http://www.youtube.com/watch?v=7W8lzDpEjAA&feature=related
Odissea Veneziana : http://www.youtube.com/watch?v=DDk5P5eGywI

vendredi 11 septembre 2009

Funny : about 'Mastering VMware Sphere 4' from Scott Lowe



Yesterday, I finally received the book about vSphere wrote by one of the best virtualization specialists worldwide : Scott Lowe. On the protect box, i saw a strange yellow sticker : "Goods Do Not Meet The Requirement Of Article 9 and 10 Of The Contract For The Foundation Of The European Community" (Roma One) Is this book out of European laws ??? Does it contains a secret ? Is it a Massive Destruction weapon ? No ! Due to coming from Aukland in New Zealand, out of EMEA area, i will probably pay so more taxes ... that's all.
What about the book itself ???? A must have !

Agenda pour les prochaines semaines

Où me trouver ?

- le 21 septembre présence chez Cisco France avec Eric Debray et Julien pour échanger sur le Nexus 5000
- le 6 octobre Palais des congrès pour les Microsoft Days
- le 8 octobre conférence sur la virtualisation lors du salon IP Convergence
- les 14 & 15 octobre Storage Expo à Londres en compagnie de Mike Workman
- Début Novembre, VMUG à la Défense, il y aura de la nouveauté dans l'air ...

Plate-forme de test Cisco

Une petite photo de famille de la plate-forme de test que je suis en train de valider pour notre nouveau MAN 10 Giga : 2 x 6513VSS, un Nexus 5010 et un ie3000 ... La baie SSD pour les bases Oracle ne devrait pas tarder :) J'ai quasiment fini de migrer la configuration COS 7.6/IOS de nos vieux Catalyst 6509 vers l'IOS 12 des 6513.
Pour compléter le tout, j'ai installé quatre (anciens) serveurs de tests sous vSphere avec le Nexus 1000V en attendant 2 serveurs bi-Xeon 5500 avec CNA Emulex commandés cette semaine. J'avoue qu'administrer un réseau à la fois virtuel et physique est un vrai plaisir. On finit même par ne plus s'en rendre compte tellement c'est naturel, en tout cas depuis l'interface CLI, On tatonne parfois avec les quelques différences entre les commandes NX-OS et IOS, mais le "?" salvateur permet toujours de s'en sortir rapidement. Le seul manque flagrant sur le Nexus physique en tout cas, c'est le protocole VTP. Celà oblige à ressaisir manuellemnt les VLANs correpondants à ceux déclarés sur les 6513. Sinon, je ne reviendrai pas sur la configuration du trunking que j'ai déjà posté précédemment. L'association vSphere/Cisco/Pillar Data, c'est vraiment une gestion ultra efficace qui permet de répondre à tous les besoins métiers rapidement et sans chichis.

mercredi 9 septembre 2009

Le n'importe quoi de la semaine : Xen 5.5 vs ESXi

... par PC EXPERT : Annoncé sur la couverture, je m'attendais à un article bien fourni avec des éléments objectifs sur l'utilisation les perfs .... Au final, une page décrivant le fait que Esxi supporte moins de plate-formes que Xen, c'est d'ailleurs pour ça qu'il existe une HCL je crois. Rien sur le fait qu'on peut l'acquérir pré-chargé sur le serveur avec garantie de résultat et support, rien sur les 60 OS supportés, les ressources utilisées en CPU et Ram. On se contentera de quelques phrases faisant vaguement état d'un vmotion Xen avec une VM sur un stockage ISCSI. Ca devait être les vacances probablement, ils ne devaient pas être très inspirés.


mardi 8 septembre 2009

Howto 10 Giga Etherchannel

Suite au post du Nexus 5000, j'ai reçu récemment plusieurs mails me demandant comment configurer de l' Etherchannel sur des liens 10 Giga Ethernet
Pour information, le principe de l'Etherchannel est de réaliser l'aggérgation de plusieurs liens de mêmes caractéristiques pour bénéficier d'un maximum de bande passante, de faire du load-balancing et de profiter de la redondance.


Passons d'abord en mode configuration
#conf term

Tant qu'à faire, on active les jumbo frame :)
system jumbomtu 9000

On définit les caractéristiques du channel

interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
exit

Il faut ensuite paramètrer les ports 10 Giga (ici sur 2 cartes superviseurs 720) et les rattacher au channel précédemment défini :

interface range TenGigabitEthernet 7/4-5
no shutdown
switchport
switchport trunk encapsulation dot1q
channel-group 1 mode auto
exit

interface range TenGigabitEthernet 8/4-5
no shutdown
switchport
switchport trunk encapsulation dot1q
channel-group 1 mode auto
end

.../...

On sauvegarde
# copy run start

On vérifie
# sh run

interface TenGigabitEthernet7/4
switchport
switchport trunk encapsulation dot1q
channel-group 1 mode auto

interface TenGigabitEthernet7/5
switchport
switchport trunk encapsulation dot1q
channel-group 1 mode auto
!
../...
!
interface TenGigabitEthernet8/4
switchport
switchport trunk encapsulation dot1q
channel-group 1 mode auto
!
!
interface TenGigabitEthernet8/5
switchport
switchport trunk encapsulation dot1q
channel-group 1 mode auto
!

En principe, la led présente sous chaque interface passera de orange ou éteinte à verte.

Est-ce que l'on cause au reste du monde ??

#sh cdp neigh
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID Local Intrfce Holdtme Capability Platform Port ID
CAT6509-1 Gig 7/3 124 T S WS-C6509 8/32
CAT6513VSS2 Ten 8/4 130 R S I WS-C6513 Ten 8/4
CAT6513VSS2 Ten 7/4 166 R S I WS-C6513 Ten 7/4
CAT6513VSS2 Ten 8/5 170 T S NX-5010 Ten 1/1

Oui, c'est tout bon, on voit bien nos voisins Catalyst 6509 et Nexus 5000 ... Notre voisin 6513 est bien connecté au travers de deux liens 10 Giga. en Etherchannel.

EMC Flare 29 est Sorti

La nuovelle release de l'OS des Clariion intègre quelques nouvelles fonctionnalités intéressantes : support de l'Ethernet 10 Giga (ISCSI) et du FC 8 Giga, Synchronisation de vCenter avec Navisphere. ... par contre FCOE, c 'est pour la prochaine fois.

Paiement sans contact : enfin un terrain d'entente

Vu sur le MagIT par Cyrille Chausson

Le NFC Forum et le Mobey Forum ont décidé d'unir leurs forces afin de promouvoir le développement du paiement mobile sans contact, via NFC. D'un côté, la technologie, de l'autre les banques, cette réunion vient rapprocher les deux mondes pour favoriser l'éclosion des services.

Lorsqu'on parle de l'avancée de la technologie sans contact NFC (Near Field Communication), l'un des principaux freins souvent évoqués est de faire assoir à la même table l'ensemble des acteurs de la chaîne, des constructeurs de composants aux opérateurs de téléphonie mobile, en passant par les fournisseurs de services, dont les banques. C'est ce à quoi pourraient aujourd'hui répondre le NFC Forum et le Mobey Forum, deux consortiums d'industriels, le premier définissant des standards autour de la technologie NFC, le second faisant la promotion des services financiers mobiles qui ont décidé de collaborer.

Leur alliance, scellée le 31 août dernier par le biais de la signature d'un protocole d'intention (Memorandum of Understanding), vise d'abord à fédérer les travaux des deux partenaires afin d'éviter de doublonner les forces au sein d'un unique projet. Puis de nouer un dialogue constructif entre les membres respectifs de chaque groupe. Leur rapprochement devrait enfin permettre de développer des standards ouverts encadrant des transactions financières mobiles sécurisées et interopérables.

A la clé, l'éclosion d'un éco-système standardisé - et surtout sécurisé - autour du paiement mobile, l'une des applications phare de NFC, pressentie comme très lucrative par les analystes. Le cabinet Juniper Research prévoit ainsi la généralisation des téléphones équipés NFC d'ici à 2013, date à laquelle le parc NFC devrait atteindre les 700 millions d'unités.

Le terme NFC désigne une technologie de transmission de données sans contact qui autorise les échanges d'informations sur de très coutes distances entre un lecteur et une puce. La technologie doit ainsi jouer un rôle essentiel dans le développement des applications de paiement mobile, mais aussi dans le monde du transport et de la sécurité (avec des applications de type passe sans contact).

Les membres du Mobey Forum, parmi lesquels on retrouve de grosses banques comme la Banque Populaire, la Deutsche Bank, HSBC, La Caixa, RBS - pour ne citer qu'eux - formeront le bataillon métier. Ils représentent l'ensemble de l'écosystème Mobile Financial Services et « communiqueront les besoins métiers critiques de la communauté financière à prendre en considération dans le développement de standards ouverts par le NFC Forum ».

Nokia, membre du Mobey Forum et déjà très en avance sur le terrain du NFC grâce à la commercialisation de terminaux sans contact et de carte SIM sécurisées, a d'ailleurs senti le vent venir. Et d'inaugurer, le 27 août dernier, Nokia Money, un service financier basique pour téléphone portable NFC.

Rappelons que le NFC Forum a décidé de jouer un rôle central et fédérateur autour du développement de standards et de services NFC. En mars dernier, le consortium s'était rapproché de l'Etsi (European Telecommunications Standards Institute) dans le but d'unir leurs standards et ainsi éviter tout risque d'éparpillement des travaux. Objectif : se prémunir contre tout retard à l'allumage des services.

lundi 7 septembre 2009

Cisco IE3000 : Première configuration

Le bloc d'alim externe de l'IE 3000 (en vert) est arrivé. Pas de problème pour le connecter. A noter en rouge la barette qui fait la liaison entre le switch et son alim et qui condamne l'un des deux contacts secs.
Lien consulter pour configurer la machine : http://www.cisco.com/en/US/docs/switches/lan/cisco_ie3000/hardware/quick/guide/ie3000gsg_fra.pdf
Pour rappel, Precision Time Protocol (PTP) IEEE 1588 est communément utilisé dans les milieux industriels pour la gestion des automates en temps réel et la précision attendue peut aller jusqu'à la nonaseconde.

Allumage de la bête :

Initializing Flash.
done.
Loading "flash:/ies-lanbase-mz.122-46.SE2/ies-lanbase-mz.122-46.SE2.bin"...@@@@ ...
File "flash:/ies-lanbase-mz.122-46.SE2/ies-lanbase-mz.122-46.SE2.bin" uncompressed and installed, entry point: 0x3000
executing...
Restricted Rights Legend
Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.
cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706
Cisco IOS Software, IES Software (IES-LANBASE-M), Version 12.2(46)SE2, RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Mon 09-Feb-09 18:59 by gereddy
Image text-base: 0x00003000, data-base: 0x01400000
Initializing flashfs...
Using driver version 1 for media type 1
mifs[3]: 1 files, 1 directories
mifs[3]: Total bytes : 258048
mifs[3]: Bytes used : 122368
mifs[3]: Bytes available : 135680
mifs[3]: mifs fsck took 0 seconds.
mifs[3]: Initialization complete.
mifs[4]: 0 files, 1 directories
mifs[4]: Total bytes : 1806336
mifs[4]: Bytes used : 1024
mifs[4]: Bytes available : 1805312
mifs[4]: mifs fsck took 0 seconds.
mifs[4]: Initialization complete.
mifs[5]: 1 files, 1 directories
mifs[5]: Total bytes : 11096064
mifs[5]: Bytes used : 380416
mifs[5]: Bytes available : 10715648
mifs[5]: mifs fsck took 0 seconds.
mifs[5]: Initialization complete.
mifs[6]: 0 files, 1 directories
mifs[6]: Total bytes : 18192384
mifs[6]: Bytes used : 1024
mifs[6]: Bytes available : 18191360
mifs[6]: mifs fsck took 0 seconds.
mifs[6]: Initialization complete.
Using driver version 1 for media type 2
mifs[8]: 675 files, 26 directories
mifs[8]: Total bytes : 64094208
mifs[8]: Bytes used : 13286400
mifs[8]: Bytes available : 50807808
mifs[8]: mifs fsck took 1 seconds.
mifs[8]: Initialization complete.
...done Initializing flashfs.
POST: CPU MIC register Tests : Begin
POST: CPU MIC register Tests : End, Status Passed
POST: PortASIC Memory Tests : Begin
POST: PortASIC Memory Tests : End, Status Passed
Initial INIT state: hi
Initial DONE state: lo
Waiting for init to go high.
Waiting for done to go low.
Start FPGA programming (375883 bytes):
- \ / -
----------------------------------------------------------------
Cesium version information from file header:
a Cesium.ncd b 2vp4fg456 c 2008/ 6/30 d 13:29: 0
----------------------------------------------------------------
POST: CPU MIC interface Loopback Tests : Begin
POST: CPU MIC interface Loopback Tests : End, Status Passed
POST: PortASIC RingLoopback Tests : Begin
POST: PortASIC RingLoopback Tests : End, Status Passed
POST: PortASIC CAM Subsystem Tests : Begin
POST: PortASIC CAM Subsystem Tests : End, Status Passed
POST: PortASIC Port Loopback Tests : Begin
POST: PortASIC Port Loopback Tests : End, Status Passed
Waiting for Port download...Complete
cisco IE-3000-8TC (PowerPC405) processor (revision A0) with 126976K/4088K bytes of memory.
Processor board ID FOC1323Z4DT
Last reset from power-on
1 Virtual Ethernet interface
8 FastEthernet interfaces
2 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.
64K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 00:25:46:A2:04:80
Motherboard assembly number : 73-10855-10
Motherboard serial number : FOC13221MLA
Model revision number : A0
Motherboard revision number : A0
Model number : IE-3000-8TC
System serial number : FOC1323Z4DT
Top Assembly Part Number : 800-28538-01
Top Assembly Revision Number : A0
Version ID : V01
CLEI Code Number : COMVH00ARA
Hardware Board Revision Number : 0x02
CIP Serial Number : 0x43313332
SKU Brand Name : Cisco

Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 10 IE-3000-8TC 12.2(46)SE2 IES-LANBASE-M

Press RETURN to get started!
*Mar 1 00:00:24.981: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
*Mar 1 00:00:25.081: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlan
*Mar 1 00:00:45.868: %SYS-5-RESTART: System restarted --
Cisco IOS Software, IES Software (IES-LANBASE-M), Version 12.2(46)SE2, RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Mon 09-Feb-09 18:59 by gereddy

Switch>en
Switch#
Switch#setup

--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: yes
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:
Enter host name [Switch]: ie3000
The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: ******
The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password: ******
% Please choose a password that is different from the enable secret
Enter enable password: ******
The virtual terminal password is used to protect
access to the router over a network interface
Enter virtual terminal password: *****
Configure SNMP Network Management? [no]: yes
Community string [public]:
Current interface summary
Interface IP-Address OK? Method Status Protocol
Vlan1 unassigned YES unset up down
FastEthernet1/1 unassigned YES unset down down
FastEthernet1/2 unassigned YES unset down down
FastEthernet1/3 unassigned YES unset down down
FastEthernet1/4 unassigned YES unset down down
FastEthernet1/5 unassigned YES unset down down
FastEthernet1/6 unassigned YES unset down down
FastEthernet1/7 unassigned YES unset down down
FastEthernet1/8 unassigned YES unset down down
GigabitEthernet1/1 unassigned YES unset down down
GigabitEthernet1/2 unassigned YES unset down down
Enter interface name used to connect to the
management network from the above interface summary: FastEthernet1/1
Configuring interface FastEthernet1/1:
Configure IP on this interface? [no]: yes*
% Please answer 'yes' or 'no'.
Configure IP on this interface? [no]: yes
IP address for this interface: 192.168.0.1
Subnet mask for this interface [255.255.255.0] :
Class C network is 192.168.0.0, 24 subnet bits; mask is /24
Would you like to enable as a cluster command switch? [yes/no]: yes
Enter cluster name: RESO-INDUS
The following configuration command script was created:
hostname ie3000
enable secret 5 *************************
enable password ******
line vty 0 15
password *****
snmp-server community public
!
!
interface Vlan1
shutdown
no ip address
!
interface FastEthernet1/1
no shutdown
ip address 192.168.0.1 255.255.255.0
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
cluster enable RESO-INDUS
!
end

[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
Enter your selection [2]:
The enable password you have chosen is the same as your enable secret.
This is not recommended. Re-enter the enable password.

ie3000#sh ru
Building configuration...
Current configuration : 1481 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ie3000
!
boot-start-marker
boot-end-marker
!
enable secret * *****
enable password *****
!
no aaa new-model
system mtu routing 1500
ptp mode e2etransparent
ptp priority1 128
ptp priority2 128
ip subnet-zero
cluster enable RESO-INDUS 0
!
!
no mac authentication
mac authentication table version 0
spanning-tree mode pvst
spanning-tree extend system-id
!
alarm profile defaultPort
alarm 3
syslog 3
notifies 3
!
alarm facility temperature primary relay major
alarm facility temperature primary syslog
alarm facility temperature primary notifies
!
vlan internal allocation policy ascending
!
interface FastEthernet1/1
ptp enable
!
interface FastEthernet1/2
ptp enable
!
interface FastEthernet1/3
ptp enable
!
interface FastEthernet1/4
ptp enable
!
interface FastEthernet1/5
ptp enable
!
interface FastEthernet1/6
ptp enable
!
interface FastEthernet1/7
ie3000#

Internet à la maison tiendra-t-il le choc face au AH1N1 ?

La préparation de liens VPN et de clients légers permettant aux employés la connexion à l'entreprise semble une voie permettant d'atténuer les effets liés à quarantaine. Toutefois, je m'interroge si l'ADSL est aussi privilégié pour les étudiants, celà va commencer à faire du monde sur la ligne .... Deux questions : Est-ce que le backbone Français est suffisament dimensionné pour accueillir simultanément tout ce petit monde ? Est-ce que nos connexions à la maison ne se freineront pas les unes les autres ?

dimanche 6 septembre 2009

Vidéo intéressante autour du Multipathing dans ESX3.5 et vSphere

Réalisée lors du dernier VMworld, à voir sur le site de Shad Sakac.

Collector le retour : les cartes SCSI PCI

Après les cartes SCSI au format ISA, j'ai remis la mains sur des cartes un peu plus récentes à savoir :
- une 2930 CU de 1997 avec connecteur HD 50
- une 2940 OU de 1996 avec connecteur HD 50
- une 29160 2000 avec connecteur HD 68.
Cette denière carte supporte le SCSI différentiel permettant le mélange de différents débits (LVD) tout en ayant une chaine SCSI pouvant atteindre jusqu'à 5 m de longueur sans perte de données.
Les 29320UW et autres 29640 UW s'appuient sur la même architecture.

Fusion Oracle Sun pas encore acquise ....

Update : Au final, l'UE pourrait laisser faire, Oracle proposerait de se séparer de mysql.

Par Pierre Berlemont - 01net

C'est un petit caillou qui s'est malencontreusement glissé dans la chaussure de Larry Ellison, le patron d'Oracle. Mais il fait mal. Alors que, fin août, la justice américaine ne voyait pas d'inconvénient à ce qu'Oracle acquiert Sun, la Commission européenne a décidé d'ouvrir une « enquête approfondie » sur ce rachat.

Conséquence, Oracle devra ronger son frein jusqu'au 19 janvier, au plus tard, pour voir s'il peut poursuivre ses projets. « La Commission doit examiner très attentivement les effets qu'aurait sur la concurrence en Europe le projet du premier fournisseur mondial de logiciels de bases de données propriétaires de racheter la première société mondiale de bases de données ouvertes », a indiqué Neelie Kroes, membre de la Commission responsable de la concurrence. En clair, la commission redoute qu'Oracle ne soit tenté de favoriser son SGBD, au détriment de MySQL.

La communauté MySQL inquiète aussi

Or, dans le même temps, MySQL connaît une forte progression. Ainsi, si les résultats financiers de Sun ne sont pas florissants – et c'est un euphémisme –, les revenus issus de la base de données libre ont grimpé de 50 % entre 2008 et 2009, même s'ils ne représentent que 300 millions de dollars environ.

D'autant qu'Oracle n'a pas été très clair sur ses intentions concernant MySQL. D'ailleurs, les utilisateurs de MySQL s'inquiètent qu'Oracle cantonne le SGBD libre au Web. Ce n'est pas un hasard si de nombreux forks sont développés par la communauté MySQL (lire 01 Informatique n° 2006) face à cette menace.

Le rapprochement Cisco EMC se concrétise

Vu sur 01net par Renaud Bonnet :

La joint-venture serait chargée de mettre en place et de commercialiser des plates-formes basées sur une combinaison de stockage EMC et de serveurs et d'éléments de réseau Cisco.

Mariage de poids lourds. EMC, le numéro un mondial du stockage sur disques, et Cisco, celui des réseaux, seraient en train de former une coentreprise pour intégrer et commercialiser une plate-forme informatique développée en commun.

La rumeur, qui tournait depuis des semaines sur Internet (nourrie par un article initial de notre confrère The Register), a été confirmée par un article du Wall Street (édition du 4 septembre), qui affirme que des recrutements sont en cours.

Baptisée provisoirement Alpine, la nouvelle structure proposerait, à des grands comptes, hébergeurs et prestataires cloud, de mettre en place dans leurs salles informatiques des systèmes composés de stockage EMC, de serveurs et d'éléments de réseau Cisco et, très probablement, des outils de virtualisation de VMware, filiale d'EMC dont Cisco possède quelques pourcents du capital.

HP et IBM de nouveau en ligne de mire

La création d'une telle structure fait sens de plusieurs manières. EMC et Cisco collaborent déjà très régulièrement, surtout depuis l'annonce par Cisco de sa ligne de serveurs UCS. En effet, l'équipementier doit proposer des solutions de stockage à ses clients éventuels pour espérer vendre ces plates-formes.

Or, EMC présente l'immense avantage de ne pas posséder d'activité serveurs, contrairement à ses grands concurrents HP et IBM. De plus, le constructeur apporte à Cisco une expertise et une garantie de sérieux dans le domaine du stockage. Depuis la présentation des serveurs UCS, la tendance chez les différents fournisseurs se porte en effet vers la mise à la disposition des clients de solutions complètes. Pour ce faire, IBM a par exemple resserré ses liens avec Brocade, qui lui fournit les composants réseaux qu'il ne possède pas.

Si Alpine voit le jour, il s'agira avant tout d'une structure de services, mais aussi de la première tentative pour les deux entreprises de s'associer aussi étroitement avec un partenaire de cette taille. Une association qui mettrait fin à des mois de rumeurs sur une éventuelle fusion entre les deux compagnies.

vendredi 4 septembre 2009

White paper Cisco/VMware sur le Long Distance vMotion

A récupérer sur le blog Datacenter de Cisco France : http://ciscodatacenter.files.wordpress.com/2009/09/white_paper_mds-et-vmotion.pdf

Telex : La SETAO va déployer le NEXUS 1000V conjointement aux Nexus 5000

J'ai l'immense plaisir de vous annoncer que nous allons enfin déployer le NEXUS 1000v au sein de nos serveurs vSphere sur notre infra FCOE reposant notamment sur du NEXUS 5000. Je tiens particulièrement à remercier Sandrine Tarnaud, qui m'a largement aidé pour l'acquisition des licenses Entreprise Plus nécessaires au fonctionnement du distributed switch et du Nexus virtuel. Dès que j'aurai quelques minutes, je ne manquerai pas de vous décrire la configuration du Nexus 1000v sur un serveur vSphere équipé des CNA Emulex ... en poussant peut-être jusqu'à l'interfaçage avec le Nexus 5000 :)

Véronique, Ed, Paul, Grant, Omar, Luca et tous ceux que j'oublie -qu'il me pardonne- c'est aussi un peu ... non beaucoup grâce à vous. Alors, un grand merci aussi.

____________________________

I'm pleased to announce that we will finally deploy the Nexus 1000v on our vSphere's servers already connected on our DCE Network. I would particularly thanks Sandrine Tarnaud, which greatly helped me to acquire licenses of Enterprise Plus for the operation of the distributed switch and virtual Nexus. Once I have a few minutes I will describe the configuration of the Nexus 1000v on a server equipped with vSphere Emulex CNA ... and interfacing with the Nexus 5000:)

Veronique, Ed, Paul, Grant, Omar, Luca and all that I forget ... thank you so much too because you are a part of this success story.

Connaissez-vous XIV Storage ?

Update : http://ds45.blogspot.com/2010/04/architecture-ibm-xiv-petite-mise-au.html

Ces jours-ci, lors d'un échange téléphonique avec l'un de mes homologues, ce dernier m' a parlé de l'existence d'un système de stockage chez IBM qui serait l'équivalent de l'Axiom de Pillar Data Systems, produit que j'affectionne parcticulièrement comme vous le savez. Ce produit a pour nom XIV. XIV est initialement une startup israélienne créée par Moshe Yanai, le concepteur des Symmetrix/DMX, après qu'il ait claqué la porte de EMC on dira 'pour divergence sur la stratégie adoptée par l'entreprise'. Tout comme Mike Workman, l'emblématique patron de Pillar Data et ex-patron de la division stockage chez IBM, ou l'équipe d'EMC qui à conçu la V-MAX, Moshe a conçu une baie modulaire sans SPOF, extrêmement évolutive. Flairant l'opportunité, XIV a été rachetée en 2008 par IBM.

Elle est architecturée autour de "Data Module" comprenant disques SATA, contrôleurs, connexions d'entrées/sorties cache, CPU et Firmware. En fait, ce sont des tiroirs de disques dans lequel on aurait à chaque fois placé l'intelligence de la baie. Chez Pillar, on dirait que les briques de disques embarquent des 'slammers' (switch fabric et cache). L'avantage théorique est d'écrire en grille les données sur l'ensemble des axes de la baie, gage de performance en relecture notamment ... effectivement comme sur un Axiom, la QOS disque en moins ! Dans le détail, chaque Data Module embarque 8 Go de cache, 12 disques, une CPU, 4 ports FC et 4 ou 2 ports Ethernet dédiés au ISCSI. Les modules dialoguent entre eux en Ethernet au travers de deux commutateurs Ethernet Dédiés en lieu et place d'un infiniband sur un EMC V-MAX.Là on touche les différences fondamentales entre un Pillar Axiom et un XIV : les briques Pillar embarquent les disques et les contrôleurs mais pas l'intelligence de la baie qui est centralisée sur le module Pilot redondant qui dirige la machine au travers du slammer. En gros les I/Os sont réparties sur les deux machines, de manière plus fine sur un Axiom -avec la QOS physique sur disque- mais là où l'intelligence est répartie sur un XIV, elle est centralisée sur un PILLAR.Le XIV peut intégrer 15 'Data Modules' contre 64 briques de disques sur un Pillar, la protection des caches mémoire d'un XIV se présentent sous la forme de 3 onduleurs APC 3KVA donnant 15 minutes d'autonomie - signe que le temps de déchargement des caches n'est peut-être pas aussi rapide que celà - alors qu'un slammer n'embarque que deux batteries tenant dans la main. Dans les faits, un XIV ne commence à être efficace qu'avec un minimum de 80 To de volumétrie pour pouvoir ventiler 40 To de données utiles ....Le réseau Ethernet interne permettant le fonctionnement et la synchronisation entre "Data Module" ne doit pas chômer. Bref c'est un beau produit techno bien complexe à développer, probablement très performant en écriture, un peu moins en lecture du fait de la synchronisation de la recomposition des données depuis les Data Module et au final moins aboutî qu'un AXIOM. Plus d'infos sur http://www.xivstorage.com/product/product_specifications.asp

jeudi 3 septembre 2009

vSphere VMDirectPath : pour virtualiser ce qui ne l'était pas encore ....

Comme je l'ai souligné lors du lancement de vSphere, VMDirectPath est un outil fabuleux ! Il permet de se sortir des contraintes imposées par le fait que certaines applications nécessitent d'avoir accès à une carte d'extension particulière pour laquelle il n'existe pas de driver virtuel. A titre d'exemple, je viens de traiter le cas de cartes industrielles Modbus qui permettent de dialoguer avec des automates. La plateforme NT4 a parfaitement reconnu la carte en question et je suis en train de finaliser la mise en place de l'application (bien entendu critique) associée. Petite contrainte toutefois : celà ne fonctionne que pour des serveurs équipés en processeur XEON Série 5000 (Nehalem).

Mon mot du jour : Quelle est la plus grosse avancée de Windows 7 ?

C'est le fait qu'il s'arrête rapidement et correctement quand on le lui demande ....

mercredi 2 septembre 2009

Collector : SCSI HBA d'il y a 15 ans ...

En recherchant des câbles SCSI pour un des membres du vmug.fr (Lionel, si tu m'entends) je suis tombé par hasard sur un carton contenant quelques trésors de guerre : de vieilles cartes SCSI Adaptec pour bus ISA (grand père de PCI)
- Une 1542CF de 1994 SCSI 8 bits avec un connecteur externe Centronics,
- Une 1542 CP de 1996 SCSI 8 bits avec connecteur HD 50
- Une 1530P de 1995 SCSI 8 bits avec connecteur HD 50

La 1530 était en fait une 154X économique car dépourvue de bios lui permettant de jouer le controleur de boot. On l'utilisait pour connecter une sauvegarde ou un scanner par exemple.
A l'époque c'était le top et on était loin d'imaginer pouvoir faire du SCSI ou du FC sur Ethernet !

VMware, la tête dans les nuages ....

Vu sur Virtuanews :

“La virtualisation, c’est tellement dépassé. Maintenant, il ne s’agit plus que de Cloud
”. Ce tweet d’un participant de VMworld à San Francisco sur twitter résume bien finalement l’état d’esprit du VMware d’aujourd’hui. La compagnie a dépassé le stade de l’hyperviseur, et ne pense plus qu’à une chose. Se faire un nom dans le Cloud, dans la cour d’un Amazon ou Google.
Un blogger résume même : “I think VMware is starting a game they better win”. (Je pense que VMware démarre un nouveau jeu, et ils pourraient gagner)
Le keynote hier, si l’on en croit les réactions des participants, était décevant. Pour les habitués de VMworld, Paul Maritz n’a fait “que reprendre les mêmes slides qu’il y a six mois, lorsque l’éditeur avait dévoilé ses ambitions dans le Cloud”. Il est vrai que peu de nouveautés ont été dévoilées. La plus intéressante, vCloud Express, une offre CaaS (Computing as a service) permettra aux clients de migrer en “douceur” vers le Cloud. Les grands hébergeurs (Terremark,rachété par VMware et Verizon, avec sa nouvelle plate-forme CaaS, ont été cités entre autres), peuvent déployer les solutions vSphere pour offrir aux clients une offre facturée à la demande. En somme, une offre qui ressemble à s’y méprendre à ce que fait Amazon EC2. La différence, selon VMware, est le mode de facturation, pour un prix “modique”. Reste à savoir si les entreprises seront prêtes à payer quelques dizaines de dollars pour créer de nouvelles machines virtuelles chez un hébergeur. A priori, oui.

Quoiqu’il en soit, et quels que soient les challenges à relever, VMware espère ainsi devenir une réféfence en la matière. L’éditeur a même soumis son API vCloud, qui permet aux autres acteurs de s’interfacer avec sa plateforme, à l’approbation du DMTF ( Distributed Management Task Force), pour en faire un standard. L’API permettrait par exemple à Cloudera, CollabNet, CohesiveFT, EngineYard, ParAccel, RightScale, rPath, SpringSource (racheté par VMware), Terracotta, TIBCO et de Zend, un ticket d’entrée pour le Cloud.

mardi 1 septembre 2009

Baie SSD Pillar Data sur Nexus 5000 mais sans vSphere ....

On m'a annoncé hier la livraison prochaine d'une 3eme baie Pillar Data Axiom 600 pour notre système d'information. Celle-ci aura la particularité d'être SSD et équipée de ce qu'il faut afin de s'intégrer sur nos Cisco Nexus 5000. Les performances attendues sont de l'ordre de 20 x celles atteintes avec des disques FC 15K. Pillar m'a d'ors et déjà indiqué que la bande passante soutenue pourra être de 2Go/s !!! Le SSD est particulièrement indiqué pour les bases transactionnelles exigeantes en I/Os mais peu gourmandes en espace disque. Pour en profiter pleinement, j'intégrerai, à mon grand regret, nos bases Oracle sur du Windows 2008 R2 avec Hyper-V à cause des fonctionnalités avancées de MultiPathing sur l'ensemble des ports du slammer (fabric du stockage) et du pilotage fin des LUNs de la baie depuis SCVMM. Ceci est lié à la totale ouverture des APIs par Microsoft, chose que VMware se refuse à faire pour vStorage : un comble ! (et ce n'est pas faute d'avoir essayé de les convaincre). La conséquence est que vSphere ne se contente de faire du "round robin" ou du "fail over" lien par lien là où un Hyper-V (même un pauvre Oracle VM ou XenServer) peut utiliser l'ensemble des liens comme n'en étant qu'un seul au travers du logiciel Pillar Data AxiomOne Path Manager. Vous comprenez de suite que le tuyau est beaucoup plus gros tout en étant sécurisé. Par analogie je dirai que c'est bien beau d'avoir un moteur de Ferarri si on est bridé par trois des quatre roues de la voiture qui proviendraient d'une smart.

Le type de serveur d'hébergement sera du bi-XEON 5500 avec deux CNA bi-canal LightPulse Emulex.

Au final, on ne saura pas encore ce que donne en grosse production transactionnelle un vSphere sur " l'état de l'art " en matière de réseau convergent, dommage ....